FWIW, I agree with Marc-Andre. Would it be ridiculous to just call the new functionality "MPI Hooks", based on what might be the most widely used similar interface, "malloc hooks"? This gets at the callback aspect that Marc mentions, but I think it also makes it pretty clear what it's for. Thoughts? Are the MPI_H or MPI_Hook_ prefixes taken? -Todd On 9/29/15, 7:07 AM, "mpiwg-tools on behalf of Marc-Andre Hermanns" <[email protected] on behalf of [email protected]> wrote:
Dear all,
currently the working title of the PMPI replacement interface is QMPI. While this is a nice homage to a system that I mostly enjoy working on, it feels to me more like an "inside joke" lacking obvious relation between name and function. Already the name PMPI was misleading, as it eventually was used for more than just "profiling".
I would propose
MPI_C_
as a basis for discussion.
It blends in well with the new MPI_T API prefix and the C would stand for "Callback". Furthermore, it describes what it _is_ rather that being presumptuous about what you do with it or who it is for (tools, ft, etc.).
What do you think? Do you have other ideas?
I know, a concrete name is not the most pressing issue we need to attend in this context, yet, in my experiences naming discussions take a long time, thus if we start this now, me might come to consensus by the time we have the rest of the API fleshed out. ;-)
Cheers, Marc-Andre
-- Marc-Andre Hermanns Jülich Aachen Research Alliance, High Performance Computing (JARA-HPC) Jülich Supercomputing Centre (JSC)
Schinkelstrasse 2 52062 Aachen Germany
Phone: +49 2461 61 2509 | +49 241 80 24897 Fax: +49 2461 80 6 99753 www.jara.org/jara-hpc email: [email protected]