9 Jul
2010
9 Jul
'10
2:22 p.m.
Quincey Koziol wrote on Fri, 9 Jul 2010 at 12:05:52
I still think aliasing MPI_Size and MPI_Count will cause problems down the line, since the two concepts are different. I'd be much happier with separating them now rather than having to change things that are switched from int to MPI_Size now to MPI_Count later.
Having MPI_Size and MPI_Count different types causes MPI_Pack/MPI_Send and MPI_Recv/MPI_Unpack to have problems, since the count and sizes are passed between the two functions and should be interchangeable, though. Do we not care, and assume the compiler will flag assignments that might result in truncation? -Fab