Hi Rolf, all, (this is mainly directed at George, Marc, and the Environment chapter committee) On Jul 22, 2012, at 3:41 AM, Rolf Rabenseifner wrote:
Martin,
Can we take this as a decision? So far there is no objection.
I am very much in favor of it - I think it makes things much less confusing. Also, I agree, so far all comments were in favor of the change.
It must be changed in tools and appLang, therefore, I need a clear decision for appLang (as chapter author).
It doesn't affect the tools chapter - it's in the environment chapter that I helped edit for the time of the meeting in Chicago. This is George's chapter and Marc's ticket, though, and we haven't heard from them. Also, George would have to implement it or at least OK the change. I can make the changes, if this is our decision, but I would need to hear from George before going in and editing. Martin
Please tell.
Best regards Rolf
----- Original Message -----
From: "William Gropp" <[email protected]> To: "Martin Schulz" <[email protected]>, "Main MPI Forum mailing list" <[email protected]> Sent: Friday, July 20, 2012 6:11:41 PM Subject: Re: [Mpi-forum] MPI_INFO_GET_ENV naming question I prefer MPI_INFO_ENV . Using GET in the name will be confusing.
Bill
William Gropp Director, Parallel Computing Institute Deputy Director for Research Institute for Advanced Computing Applications and Technologies Paul and Cynthia Saylor Professor of Computer Science University of Illinois Urbana-Champaign
On Jul 19, 2012, at 12:25 PM, Schulz, Martin wrote:
Hi all,
During the chapter review for Chapter 8, the environment chapter, a question came up at the forum, which we thought requires wider feedback.
Ticket 313 introduced an info object into MPI 3.0 that allows users to query the environment, which is called MPI_INFO_GET_ENV. This name, however, contains a verb and hence follows the naming structure of an MPI function, but is a constant. Hence, should we really go with this name or should we rename this into a name without a verb, like MPI_INFO_ENV, to avoid confusion? People in the room were leaning towards the latter and this is clearly ticket 0 at this point, but we wanted to ask to make sure there is no unintended impact with that change.
Comments? Thanks,
Martin
________________________________________________________________________ Martin Schulz, [email protected], http://people.llnl.gov/schulzm CASC @ Lawrence Livermore National Laboratory, Livermore, USA
_______________________________________________ mpi-forum mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-forum
_______________________________________________ mpi-forum mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-forum
-- Dr. Rolf Rabenseifner . . . . . . . . . .. email [email protected] High Performance Computing Center (HLRS) . phone ++49(0)711/685-65530 University of Stuttgart . . . . . . . . .. fax ++49(0)711 / 685-65832 Head of Dpmt Parallel Computing . . . www.hlrs.de/people/rabenseifner Nobelstr. 19, D-70550 Stuttgart, Germany . (Office: Allmandring 30)
________________________________________________________________________ Martin Schulz, [email protected], http://people.llnl.gov/schulzm CASC @ Lawrence Livermore National Laboratory, Livermore, USA