This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "MPICH primary repository". The annotated tag, v3.2b1 has been created at 810291da3c4e7d0f972872a9175ecfaa73f9a6ba (tag) tagging 2524cea29f887df330259ad53706a16ed83ac869 (commit) replaces v3.2a2 tagged by Antonio J. Pena on Sun Mar 15 21:23:40 2015 -0500 - Log ----------------------------------------------------------------- tagging 'v3.2b1' Antonio J. Pena (17): Add Immediate versions of nonblocking coll. I/O Enable MPI 3.1 MPI_Aint address arithmetic functs. Changed MPI_SUBVERSION to 1 Mark coll/alltoallw1 as xfail (ticket 2180) Marking threads/alltoall as xfail (ticket 2199) Marking pingping as xfail (ticket 2239) Increase timeLimit for pingping Mark FT multi_isendalive test as xfail Changed MPICH version to 3.2b1 Added ft/barrier as xfail Mark ft/isendalive as expected to fail Mark ft/reduce as expected to fail Revert "Changed MPI_SUBVERSION to 1" Revert "Enable MPI 3.1 MPI_Aint address arithmetic functs." Revert "Add Immediate versions of nonblocking coll. I/O" CHANGES file for 3.2b1 release Marked ft/nvccoll test as expected to fail Charles J Archer (7): Open Fabrics Working Group (OFIWG) Netmod Support Compile time fixes to latest OFI interfaces Open Fabrics offical name is OFI rename from SFI Include uppercase SFI to OFI in netmod rename Updates to latest OFI pre-1.0 release Compile time fixes to the latest rc of OpenFabrics Interfaces Updates to latest OFI api (endpoint attribute location change) Huiwei Lu (4): FT: Fixes ref counts in shrink and agree Mark comm_idup_overlap as xfail Mark comm_idup and comm_idup_mul as xfail Adds a note of deprecating Myrinet MX to CHANGES Igor Ivanov (2): mpid/sched: Fix issue with schedule entries list processing mpi/coll: Fix a bug in MPI_Scan James Dinan (2): Fix error class buf in MPI_Error_add_code Add dynamic err code, predefined err class test Jithin Jose (1): Updates for latest OFI-libfabric API Junchao Zhang (14): Fix a typo for MPI_TYPE_NULL Fix an arg name in MPI_Comm_set_info Fix an arg name in MPI_TYPE_NULL_DELETE_FN Add MPI_Status_f2f08 & MPI_Status_f082f Fix misleading text in doc for error code MPI_ERR_TYPE Fix a typo in mpivar.c Update libtool and automake versions in release.pl Add new MPI_T routines and an error code in headers Implement new MPI_T routines to get vars/categories by name Add error names for newly added MPI_T routines Add a test for the new MPI_T_xxx_get_index() routines Add a generic error code MPI_T_ERR_INVALID of MPI-3.1 Fix weak attribute interface for new MPI_T routines Change MPI-3.1 MPI_T stuff to MPIX_T Ken Raffenetti (28): use 0 to indicate false in while expression portals4: handle PTL_NO_SPACE portals4: raise list size limit portals4: add macro for safe PtlMEAppend ch3: cleanup abort code implement PMI_Abort modify fatal error handler fixup test for abort with fault tolerance fixups for revoke_shrink test add generated testlist file to .gitignore hydra: fix zero-length format string warnings remove mpl/opa libs from external flags when embedded disable libtool versioning for embedded libraries Fortran profiling interface fix patch libtool for ifort on darwin add FCMODOUTFLAG to FC_COMPILE_MODS rptls: do not send pause/unpause messages to self correct tag usage in MPIC_Sendrecv portals4: remove dead code portals4: simplify send callback require automake >= 1.15 require libtool >= 2.4.3 portals4: simplify operation tags in RMA code portals4: encode rank in match bits instead of header portals4: use portals4 hdr_data for length info portals4: change variable name testsuite: move coll alias checks to errors dir testsuite: remove leading spaces in testlist files Kuleshov Aleksey (1): Fix bug in using wrong type for packsize. Min Si (6): Add info check to avoid unnecessary SHM detection. Add tests for SHM detection in win_create. Set default test level of mtest-datatype through env var. Simplify test setting of min/full datatype tests. Fix win size translation in attrlangf90 test. Use the same basic dt in mtest derived dt tests. Norio yamaguchi (2): Fix implementation of RMA in netmod-IB Bug-fix : leak mutex unlock in netmod-IB Paul Coffman (4): Criteria for disabling pami optimized collectives invalid on BGQ romio gpfs: select correct read buffer romio gpfs: select correct read buffer addendum barrier in close whenever shared files supported Pavan Balaji (4): Remove old unused errnames. No need to namespace a static function that is unused outside. Move static function to sit inside !defined MPICH_MPI_FROM_PMPI. Fix xfail format. Rajeev Thakur (2): Changes the sticky lb/ub fields in resized types to 0, since the lb/ub Fix MPI_Info_get to pass valuelen+1 to MPIU_Strncpy and check return Ralph Castain (1): ROMIO: Add missing files to Makefile.mk 'noinst' Rob Latham (7): make ADIOI_Shfp_fname report errors use PATH_MAX instead of magic number Tweak MPIDU_Datatype_debug output clean up 64-to-32 bit casts fix issue with small i/o and big datatypes check for avialablity of pwrite remove _XOPEN_SOURCE in code Sameh Sharkawi (1): PAMID: Initial CUDA support Sangmin Seo (3): Fix async progress problem in NBC I/O. Mark iwriteatallf as xfail Do not reference a CH3 variable in ROMIO glue. Su Huang (2): PAMID: misc chnages in pamid to support MPICH 3.2 PAMID:MP_STATISTICS=print will cause mpi hw case coredump Wesley Bland (38): MPID_Request_is_pending_failure always returns 0 in pamid Fix bug in shrink when serializing failed procs Add agree_shrink to testlist Fix typo in error code man page Bring test suite version in line with MPICH Don't free a request if it still pending Strip out pending ANY_SOURCE request handling Break out of progress for anysource failures Handle anysource in the wait* functions Allow MPIR_Request_complete to take a NULL request Make anysource test more accurate Handle anysource in blocking recv functions Change MPIDI_CH3I_Comm_AS_enabled to be MPID level Move MPID_Comm_AS_enabled to MPID layer function Remove ADI breakage introduced earlier Refactor MPI_Testall to have an MPIR version Fix for MPIX_COMM_AGREE to not return incorrect errors Refactor MPIC_Wait to return an errflag Refactor MPIC functions to use the MPID objects Add MPIC_Issend Move mpir_errflag_t to mpitypedefs.h Add mpir_errflag_t to MPIDI_Request Convert scheduler functions to use MPIC Add test for non-blocking collective failures Correctly return errcode for NBC Fix a bunch of bugs in the scheduler Adds mpiimpl.h include to sock.c Moves errflag in request from device to top level Add weak symbols for MPIX functions Don't check for anysource if not recv Only process recv requests Clear error bits in MPIC functions Remove unused variable in alltoallw Mark failing FT tests as xfail for now Mark ft/scatter as xfail Mark more ft tests as xfail. Mark more ft as xfail Mark ft/die as xfail William Gropp (6): Make ROMIO htmldocs update link file Check for endif in f77tof90 to avoid false warning Add support for procs-per-node to testsuite runs Update test suite README Correct testsuite dist target support Add timelimit option Xin Zhao (107): Bug-fix: preventing completing the same RMA request twice. Code-refactor: arrange RMA sync functions. Code-refactor: arrange RMA pkt structure. Clean up unused attributes in RMA packet structs. Bug-fix: correctly modify win_ptr->accumulated_ops_cnt Bug-fix: check win_ptr->active_req_cnt in RMA sync calls Bug-fix: handle dest==MPI_PROC_NULL in Win_flush/flush_local Bug-fix: in UNLOCK handler, send FLUSH_ACK first, then release lock. Perf-optimize: support piggybacking LOCK on large RMA operations. Bug-fix: add IMMED area in GET/GACC response packets Perf-optimize: avoid FLUSH/FLUSH_ACK messages if no PUT/ACC. Bug-fix: set put_acc_issued flag correctly Use int instead of size_t in RMA pkt header. Code-refactor: move piggyback work from op routines to issue rountines Bug-fix: modify free_ops_before_completion function Poke progress engine in RMA sync call when needed Do memory barriers at proper places in RMA sync calls. Check if all targets are freed at end of RMA sync calls. Bug-fix: always allocate ranks array in Win_start. Reset/release window attributes in RMA sync calls. Set window epoch state at proper places in RMA calls. Use window pool to manage lock requests Change struct name from MPIDI_Win_lock_queue to MPIDI_RMA_Lock_entry Modify struct name: replace "struct XXX" with "XXX_t" Re-organize progress engine functions. Code-refactor: Move send_flush_msg function to header file. Bug-fix: add pkt type LOCK in GET_TARGET_WIN_HANDLE macro Change routine/pkt name from LOCK_GRANTED to LOCK_ACK Add new pkt flags for different LOCK ACKs. Modify send_lock_ack_pkt function to contain flags. Modify ACK of op with both LOCK and UNLOCK (FLUSH) flags Delete MPIDI_CH3_PKT_FLAG_RMA_UNLOCK_ACK flag Tracking current buffered lock data on each window Support handling different LOCK ACKs Avoid memcpy if we decided to drop current op data. Setting infos in win_init function. Add check no_locks info in set_info function. Change function name: set_lock_sync_counter -> handle_lock_ack Bug-fix: first dequeue lock entry from queue, then perform op in this entry Bug-fix: store lock entry pointer in request even data is dropped Simplify epoch checking in Win_lock Delete unnecessary code in SHM allocate / free. Bug-fix: making processes with SHM and without SHM win work corrrectly. Add tests to test cases when both SHM window and non-SHM window exist. Bug-fix: guarantee atomicity for FOP and GACC. Add tests to test the atomicity for FOP, CAS and GACC operations. Temporarily revert commits for src/mpid/ch3/include/mpidpkt.h Revert "Code-refactor: arrange RMA pkt structure." Re-apply modifications on mpidpkt.h. Modify packet wrappers to make them complete. Add comments about RMA packet wrappers. Remove lock_type and origin_rank areas from RMA packet. Code-refactoring for RMA operations routines. Rewrite code of piggybacking IMMED data with RMA packets. Add asserts for RMA packet types. Change argument of function finish_op_on_target. Use memcpy for structure assignment. Bug-fix: use do_accumulate_op function for ACC computation. Bug-fix: when encounter mpich failure, unlock inter-process lock. Remove source_win_handle from GET-like RMA packets. Simplify code of issuing RMA packets. Delete unnecessary code. Delete comments that no longer make sense. Bug-fix: add barriers between init buffers and issuing RMA operations. Clean up white-space and code format in RMA code. Add CH3 APIs and macros to allow channel to implement Alloc_mem/Free_mem. Change name of MPIDI_CH3U_Win_create_gather to MPIDI_CH3U_Win_gather_info. Store window basic attributes into a struct on window. Reduce size of shm_base_addrs[] from comm_size to node_size. Add a function hook to initialize window attributes in channel layer. Allow the channel layer to implement Win_gather_info function. Use function hook instead of function pointer for win_free. Simplify code: not using flag MPIDI_CH3_PKT_FLAG_RMA_IMMED_RESP for GACC/FOP. Simplify code: deleting derived DT code for op piggybacked with LOCK. Add FIXME about extending piggybacking LOCK to op with derived DT. Code-refactoring: set iov in issue_from_origin_buffer. Modify macro PAIRTYPE_SIZE_EXTENT to accept correct arguments. Make 'eltype' in datatype struct store basic type. Bug-fix: make RMA work correctly with pair basic type. Change name from data_size to buf_size. Code-refactoring: make perform_get_acc_in_lock_queue cleaner. Modify location of setting next_op_to_issue and sync_flag to NONE Code refactoring: setting ureq after issuing op in a function. Code refactoring: set ureq to NULL when creating op. Return request pointer from issue_from_origin_buffer function. Increment active_req_cnt when issuing the packet. Use a request array in RMA operation. use MPIDI_CH3U_Request_complete to complete user request. Make create_datatype be able to create more general new datatype. Split issue_from_origin_buffer into normal and stream version. Cutting ACC and GACC messages. Make sure we only copy dataloop once for each RMA operation. Reset flags for stream unit within one RMA operation. Add counter in op struct to remember number of stream units issued. Add stream_offset to ACC-related packets and request struct. Correct the name of RMA requests types. Bug-fix: add FOP req types. Modify do_accumulate_op to allow for packed basic type data as input. Modify RMA pkt handlers and req handlers to allow for stream units. Allocate buffer with stream size for ACC/GACC data piggybacked with LOCK. Modify SHM ACC/GACC to avoid allocate large buffer. Correct the usage of req's segment_first and segment_size in sendNonContig Rename eltype, n_elements and element_size to better names. Modify comments about basic_type, n_builtin_elements and builtin_element_size. Rename predefined_type / predef_type to basic_type. Add a test code to test Accumulate operations working with pair type. Change file name ch3u_rma_oplist.c to ch3u_rma_progress.c andrey.lobanov (1): fixed memory leaks in pmi messages handling artem.v.yalozo (2): Windows conformance: RMA mutexes added missed brackets in MPL_LL_DELETE_VS2008 macro ----------------------------------------------------------------------- hooks/post-receive -- MPICH primary repository