This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "MPICH primary repository". The annotated tag, v3.1rc1 has been created at 9cc2099cc86beaa2a1c47a29658172f76394db62 (tag) tagging 6a9def627a35fe6c7d1a08dffd39a6387dbffe83 (commit) replaces v3.1b1 tagged by Antonio J. Pena on Tue Nov 5 22:52:42 2013 -0600 - Log ----------------------------------------------------------------- tagging 'v3.1rc1' Antonio J. Pena (4): Increased tmp string buffer len from 1K to 16K Updated release information for 3.1rc1 Partially revert 9088ea81 Removed ABI mention from CHANGES Dave Goodell (1): large count work: use MPI_Aint for dtype size and collectives Huiwei Lu (3): Fixes #1851 - sizeof() usage inconsistencies in sock.c Adding a test case for MPI_Comm_idup Add comm_idup_mul to .gitignore Jan Bierbaum (1): fix check for duplicate KVS entries Jeff Hammond (3): update discuss email address return result of strlen to proper type remove cast-to-integer associated with count field Junchao Zhang (32): Make mpi_t_str always fail when MPI_T is not done Add MPI_T return codes. Fix #1905 Return MPI_ERR_INTERN for not-impl MPI_T functions Add the missing constant MPI_T_SCOPE_CONSTANT Add a test mpit_vars.c to print all MPI_T stuffs Primary implementation of MPI_T specified in MPI3 Replace mpi_t_util.c with mpit.c In MPI init/finalize, use updated MPI_T routines Delete the old interfaces on pvars Change var names in enable_pvar_* style Change wording for option --enable-mpit-pvars Adapt old nemesis pvars to new MPI_T impl Adapt old ch3 pvars to new MPI_T impl Capitalize parameter category names Add missing info of parameters (cvars) Revise genparams to gen files needed by new MPI_T Rename mpich_param_vals.h, param_vals.c Rename cat_get_pv.c to cat_get_pvars.c Rename mpit_init_thread.c to mpit_initthread.c Revise the test case mpit_vars.c Revise two tests under test/mpi/manual/mpi_t/ Delete xfail=ticket1898 of mpi_t_str Add a test case to test multithreading MPI_T Rename parameters MPIR_PARAM_* to MPIR_CVAR_* Rename mpich_params.{c,h} to mpich_cvars.{c,h} Fix a problem in passing thread id to a function Swap the priority between MPICH_* and MPIR_PARAM_* Use the new MPI_T cvar name prefix MPIR_CVAR_ Include mpitimpl.h in mpich_cvars.h Use the standard #ifndef/#include in mpitimpl.h Set almost all cvar scope as MPI_T_SCOPE_ALL_EQ Correct the cvars names and delete unnessary init Ken Raffenetti (10): Fault Tolerance test fixes. Remove Linux-isms in test code. Test for PTHREAD_PROCESS_SHARED attribute Change to PMI proxy on unknown key lookup Update fault tolerance test params turn off TAP xfail info for passing tests Add resultTest routine to test suite. Fixup and add pt2pt fault tolerance tests Fault tolerance tests for some collectives Disable xfail test from running by default Lisandro Dalcin (1): Fix for uncommitted datatypes Michael Blocksome (1): Fix pamid bgq configure for v1r2m1 installs Pavan Balaji (50): Trigger the RMA error more frequently. Update version and CHANGES for 3.1b2 Fix range format in README.envvar Explain default port range for CH3_PORT_RANGE. Revert "Fix range format in README.envvar" Added a link to the bugs fixed. Check whether todo tickets are valid. Mark transp-datatype as xfail. White-space change for consistency. Remove stale information from README.vin Upgrade to hwloc-1.7.2. Hydra-specific patches for hwloc. Update README with hwloc version. Cleanup multiple aspects of the is_local lookup. Improve the win_shared test to check for more errors. Updated changes with RMA improvements. Improve test to not rely on the default alloc_shm. Win_flush_all optimization. Do a memory barrier at the end of a flushall. Simplify checks for shared memory windows. Move predefined datatype check to the MPI layer. Optimize localcopy for predefined datatypes. Optimization to the shared memory copy code. Check for BUILTIN kinds, not just predefined datatypes. clang compilation fixes. Warning squash. Change the MPI_MAX_ERROR_STRING back to 512. Renumber MPI_COMBINER constants to maintain ABI. Fortran ABI changes from Intel. Update libmpich ABI string for the 3.1b2 release. Bug fix for the mpit_vars test. Added information about MPI_T to the documentation. Update version string. Correct output format in the new impls/ test. Revert "Fix for #1804 - Alignment issues in Fortran with MPI_Status" MPI_Status updates for ABI. Fortran updates for MPI_Status. Remove bogus checks for MPIF_STATUS size. Bug fix for MPI_WEIGHTS_EMPTY. Fix to buildiface when Fint != int. Added MPICH ABI information to CHANGES. Updated git link. Added a nonblocking MPI_Test test. Mark nbtest as xfail. Move the errors/f77/errhan directory to an iodir. Mark comm_idup_mul as xfail. Remove xfails for ticket 1893. Fix perl warnings in the C++ buildiface. Fix bit manipulation in the MPI_Status object. Fix assertion for large counts. Rob Latham (38): use AS_VAR_ARITH add error checking to aio test fall back to blocking version if aio not implemented Improve aggregation selection on Blue Gene Datatype test describing large amounts of data add make rule for large_type and typo in testlist Improvements to large_type test Maintain requested perms in more cases remove unused, undeclared variable reduce duplcated code in hint processing clean up tests with enable-strict improved error handling for test/file_info unused variable warning update adio drivers to use common hint processing funcs improve comments, formatting on some tricky code compile error removed unused variable clang finds an incorrect header guard teach type-dumping code about subarray another big type test Configure check for (need for) header padding ROMIO: improve handling of large datatypes Increase size of internal datatype values More ROMIO updates for large count resized wasn't setting max_contig_count implement MPIU_Assign_trunc without _Generic datatype_size no longer needs to be an integer make shared file pointer code "large datatype" safe A round of 64-to-32 warning squashes Small parens-related warning with clang casting to make formatting happy remove MPIR_Type_get_contig_blocks defective MPI_Pack/Unpack/Pack_size interface type promotion for MPIR_Bsend structure fix MPI_T test failure due to uninit variables testcase for status object manipulations Align nemesis payload: union approach blurb about large count/type changes Wesley Bland (7): Fixes #1923 - Incorrect error message. Remove Windows section from User Guide. Remove Windows section from Install Guide. Add note about MPI_Init accepting NULL. Add documentation for errhandler callback Reword the mpiexec usage guide. Fix bad quote character in the last commit. William Gropp (18): Minor fix for typo in documentation comment Fix two errors in basic MPI_T test Removed duplicate Make target and make clean commands consistent Add FIXME for reduction operation macro Removed irrelevant comment Add comment on end of PMPI ifdef to improve readability Fail instead of continuing with broken environment Removed trailing blank Check for other Testmpio locations Ensure MPIR_COUNT_ALIGNMENT set Add way to test implementation specific features Allow MPI_ERR_IO as error class in test Change buildiface for C++ to control output order Add option to remove distgraph support in C++ Detect unknown feature request Remove support for MPI::Distgraphcomm Eliminate test for C++ Distgraphcomm routines Force ordering of functions in C++ binding Xin Zhao (18): fix bug on "list_complete" variable set disp_unit in win_shared_query. fix bug: add a memory barrier in win_fence. fix bug: delete memory barriers in win_post/start. fix bug: delete memory barriers in win_lock/lock_all. change the condition of memory barrier. Delete judgements of datatypes of RMA operations. Delete MPIDI_CH3I_DO_SHM_OP macro. perform SHM operations immediately. eagerly acquire lock in win_lock/lock_all for SHM operations. Allocate shared memory by default for WIN_ALLOCATE Update FLAVOR checks with shared memory checks. Change FLAVOR to shared memory checks in win_flush. delete exit after do memory barrier. fix bug:pass info to win_allocate and free info. make MMAP SHM handle as MPI_Aint type. Add a test for allocating 1GB SHM window memory per process. Multi-threaded RMA test. ----------------------------------------------------------------------- hooks/post-receive -- MPICH primary repository