This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "MPICH primary repository". The annotated tag, v3.2b4 has been created at 978d7ba7212d14d6399733459c982151545745c8 (tag) tagging b5099d559d6c2a406d3b875b054c288c7e306bc7 (commit) replaces v3.2b3 tagged by Pavan Balaji on Fri Jul 24 23:20:25 2015 -0500 - Log ----------------------------------------------------------------- tagging 'v3.2b4' Antonio J. Pena (3): netmod/portals4: Enforce ordering in RMA Moved MPIDI_QUOTE to MPIU_QUOTE Moved MPIU_RMA_CALL to MPIR_RMA_CALL Antonio Pena Monferrer (3): netmod/portals4: Use persistent ME in RMA netmod/portals4: Remove unused field in netmod req Fix a bug in GENERIC_Q_SEARCH_REMOVE + empty queue Charles J Archer (4): OFI Netmod: Improve *msg functionality and fix bugs Progress registration fixup for pamid device OFI Netmod: Use max port name for maximum bound address length OFI Netmod: Temporary VC fixes for spawn tests Hajime Fujita (6): Remove HAVE_GPID_ROUTINES macro Cleanup: MPIDI_RMA_* prototypes must be private Cleanup: MPIR_Rank_t should be MPIDI_Rank_t Cleanup: Nemesis-specific symbols must begin with MPIDI Cleanup: Move Nemesis-internal prototypes to impl.h Remove MPID_TimerStateBegin/End functions Halim Amer (8): Fixed several issues related to Ibsend Mark the failing send cancel related tests as xfail Test send cancellation issues with unmatched sends Added tests to stream ACC-like RMA ops Added a code cleanup script Marked the multithreaded commu_idup test as xfail Promote the count argument to MPI_Aint in some send routines Advise against using sleeping routines to implement the yield functionality Huiwei Lu (8): Change MPI_Comm_idup test to be more strict Fixing multiple MPI_COMM_IDUPs in the same communicator Remove xfail for ticket 2269 Mark comm_idup_comm as xfail Mark threaded MPI_COMM_IDUP tests as xfail Adds tests for threaded collective operations Fixing testlist for threads/coll Remove xfail for MPI_Comm_idup Jithin Jose (2): Handle error-event for fi_cancel OFI-Netmod - Handle error event for truncated message Junchao Zhang (18): bug fix and add @WRAPPER_LDFLAGS@ to final_ldflags Increase MAX_F90_TYPES to 64 Add a progress hook mechanism to ch3 and nemesis Add a progress hook mechanism to sock Add a progress hook mechanism to pamid Fix typos in an F08 test Move (P)MPI_Aint_add/diff up before (P)MPI_T Add prototypes of MPI_Aint_add/diff to the F90 mpi module Add a mechanism to remove F77 only lines in f77to90 translation Move MPI dataypes out of array initialization Add more cases to generate var intracommunicators Renamed routine TestIntercomm, moved it to mtest.c Test for multithreaded idup overlapped with nbc. Mark idup_nb.c as xfail Do not do testing on null communicators Mmultithreaded test to overlap idups with comm gen-functions Remove xfail for idup_comm_gen Mark idup_comm_gen with xfail=ticket2286 Ken Raffenetti (15): update CHANGES to reflect the MPI-3.1 standard netmod/portals4: fix bug in setting count added CHANGES note about support for OFI answer FIXME in comment for MPIDI_CH3U_Recvq_FDU netmod/portals4: remove unused variable netmod/portals4: fix per target event counting netmod/portals4: use separate EQ for flow control handling netmod/portals4: remove packing utility functions netmod/portals4: cleanup usage of unused variable netmod/portals4: build on persistent GET ME design netmod/portals4: remove unused variables ch3: revert accidental change of context_offset type netmod/portals4: update format specifiers portals4: use dummy buffer for NULL send/recv tsuite: increate epochtest timeout Lena Oden (18): Check if type_tag is agnostic to modifiers. Add a isend-irecv test for multiple processors Handling of discard connection to avoid reconnect Close remainig conns before sockset is destroyed remove a wrong colon Add new comm_idup test: overlap with iallreduce Add new test to overlab comm_idup with nb-coll. Mark new comm_idup tests as xfail New comm_idup test, overlap with isend/irecv Add a test to test overlapping Comm_idup with other comm. gen functions Fix memory leaks in test/mpi/comm/comm_idup_nb Add test for non-blocking collectives for intercom Bugfix for MPI_Ibarrier for inter_communicators Bugfix for MPI_Iallgather for intercommunicators. Remove xfail, since #2284 is fixed Fixes test/mpi/comm/comm_idup_comm Add initialization for own_mask. Remove xfail for test/mpi/comm/comm_idup_comm Masamichi Takagi (5): Add Hatanaka version of MTR netmod files (tofu/*) Add errnames.txt for the Tofu netmod Implementing the Tofu netmod Add entries in errnames.txt Rename from match field of LLC_cmd_t to tag Massa. Hatanaka (1): Bug Fixes for netmod-llc Michael Blocksome (1): Move the PAMID GPID routines from mpidpre.h to mpidpost.h Min Si (10): Move outstanding_acks increment to flush sending step. Always free issued OPs when window resource is used up. Expose AM flush ordering and issue per OP flush if unordered. Bugfix: free internal req object in fn_fail. Redefined RMA extended packet header in CH3 layer. Fixed bug in atomic read-modify-write FOP/GACC/CAS tests. Added test to check remote completion of RMA+flush. Rewrote MTest collective wrapper routine. Replace @PERL@ in maint/ with "/usr/bin/env perl". Replace hard coded perl path with @PERL@. Norio Yamaguchi (25): Fix update request status after receiving data Fix the buffer address for send/recv Add memory release operation Time trace with rdtsc Wait until all UNSOLICITED are done Revert "Time trace with rdtsc" Fix for SC14 Fix memory leak Disable dependence on libmemcached Implement tag matching for ANY_SOURCE and ANY_TAG Implement iprobe and improbe in netmod-tofu Implement issend in netmod-tofu Override rsend and irsend x86 don't care 8byte alignment in llctofu_poll Modify some functions for RMA Fix implementation when receiving a event Delete debug code Fix conversion from LLC rank to MPI rank Revert "Override rsend and irsend" Add cancel_recv function Override rsend and irsend Fix build warnings in netmod-tofu Handle TARGET_PROC_FAIL event Avoid optimization when compiling with O2 Delete incorrect decrement Norio yamaguchi (1): Performance : allocate a memory for a command and vectors at once Pavan Balaji (45): Remove xfails for some more tests. Renamed tofu to llc. White space cleanup. Fix llc Makefile file inclusions. Remove the IB netmod. Edit CHANGES and README.vin to remove IB mentions. White-space cleanup. MX is deleted, not deprecated. Prepare for the 3.2b4 release. xfail gather_big test. Remove unnecessary asm checks for nemesis. Remove test/mpid. Remove unused parameter. Get rid of unused lrank element in lrank_to_lpid structure. Remove redundant definitions. Revert "Remove redundant definitions." Remove unused finishpending functions. Added a script to detect git conflicts. Fix management of -g in CFLAGS. Fix bug in the mtest.c file. Deleted MPID_REQUEST_SET_COMPLETED macro. Replace MPIDI_CH3U_Request_complete with MPID_Request_complete. Change MPID_Request_set_completed to MPID_Request_complete. Use better variable name in macro. Avoid destroying request directly. Initialize comm local and remote size to -1. Remove namespacing for static functions. Call device hooks on a communicator before its child communicators. Move VCR-specific content to the device. We no longer have the '--disable-smpcoll' configure option. Added a note about the hwloc build issue with PGI. Updated to hwloc-1.11. Hydra-specific patches for hwloc. Warning squash: Avoid assigning const char * to char *. Fix for hwloc's failure with PGI 32-bit compilers. Revert "Added a note about the hwloc build issue with PGI." Use MPIDI_RMA_Win_list_head instead of MPIDI_RMA_Win_list. Remove unnecessary initialization. Remove unnecessary patch that was carried forward. Minor correction to the git-conflicts script. Move default PMI version to the device. Get rid of MPIUI_Memcpy. Remove unnecessary macro. nb_test is incorrect, not an xfail. Setup a configure option to disable comm_overlap tests. Rob Latham (15): some type promotions in RMA path better approach for do_accumulate_op fixes for test case promote more types to larger versions a "large contig" type Update PAMI device for larger count types hoist ROMIO init into MPI_Init record lb and ub index in flattened adjust flattened processing for repeated resize mark gather_big as a 'largetest' Increase number of finalizers clean up 62829ab8: generate testlist properly Revert "hoist ROMIO init into MPI_Init" system calls return ssize_t, not int Test case for segfault in spawn Sangmin Seo (4): Create htmldir before installing html files. tsuite: add MPI version setting to runtests. Mark ft/agree as xfail. Fix wrong xfail usages. Valentin Petrov (1): OFI netmod: RCD protocol bug fix. Wesley Bland (1): CH3: Remove unnecessary message queue searching Xin Zhao (91): Issue extended packet header in OFI netmod. Add a test for large ACC operations working with MPI_Win_flush_local. Fix in Nemesis: assign sreq to shm_active_send when headers are sent. Add tests of setting window info no_locks to TRUE / FALSE. Bug-fix: fix typo error in Win_set_info. Bug-fix: free lock entry queue when it was allocated. Add a test to test atomic GET (GACC/FOP + MPI_NO_OP). Delete macros that no longer needed. Change op pointer name 'new_ptr' to 'op_ptr'. Delete useless IF branch. Simplify code: use MPIDI_CH3U_Request_complete to complete user request. Simplify code: delete unncessary calculation in IMMED length. Remove unused have_remote_incomplete_ops. Remove "is_dt" flag from op structure. Add "_head" to name of linked lists. Add "issued_" prefix to read_op_list, write_op_list and dt_op_list. Move disable_flush_local into sync struct and rename it. Simplify code of garbage collection functions. Delete redundant variable "len". Change variable name of origin data_sz and target data_sz. Fix typo error on variable names. Add namespace for num_active_issued_win and num_passive_win. Code-refactoring: move completion judgement code out of GC function. Delete redundant function call. Exit immed_copy() if src/dest address is NULL or data length is zero. Make do_accumulate_op() perform correctly when op is MPI_NO_OP. Delete redundant branch for MPI_REPLACE. Add comments about MPI_NO_OP in GACC/FOP. Bug-fix: datatype in FOP should be predefined instead of builtin Delete code of converting GACC/FOP to GET when op is MPI_NO_OP. Modify MPICH infrastructure to support atomic GET. Change function name used in RMA progress. Return a flag from check_and_switch_target/window_state() on issuing ops. Move check_and_switch_target/window_state() into issue_ops_target/window(). Delete redundant function call. Increase time limit of test/mpi/rma/atomic_get test to 5 min. Use MPIDI_msg_sz_t instead of int for orig_segment_first. Bug-fix in calculating streaming size in GetAccumulate pkt handler. Bug-fix in Request_load_recv_iov() when initial value of segment_first is not 0. Bug-fix on typo error. Simplify code: using MPIDI_CH3I_RMA_Ops_free_elem to delete operation. Code format clean up. Bug-fix: correct local/remote completion in Win_flush_local. Bug-fix: correct SHM memory size in Nemesis Win_gather_info(). Bug-fix on mpi/rma/manyget.c test. Only make RMA progress when ISSUED active win or passive win exist. Perf-tuning: overlapping issuing data and computation on target side in GACC/FOP. Modify MPI_Win_complete to only wait for local completion. Delete unnecessary progress in MPI_Win_fence. Adding reduce-scatter based algorithm in MPI_Win_fence. Delete poke_progress_engine in RMA sync calls and only keep self lock cases. Bug-fix on setting MPIDI_CH3I_num_active_issued_win. Perf-tuning: avoid dynamic allocation of requests in RMA. Delete CVAR and code that control the batch issuing of RMA operations. Delete a CVAR that is never used. Add prefix "target_" to lock_entry related name and suffix "_head" to linked lists. Bug-fix: always allocate target lock entry pool in win_init. use ALL_STREAM_UNITS_ISSUED to indicate if all stream units are issued out. Add DELAY_ISSUING_FOR_PIGGYBACKING option for RMA synchronization. Better judgement on if it is OK to issue operations. Add progress poking and GC progress during issuing out the ops. Poke progress engine in RMA op/sync routines when state is not satisfied. Set upgrade_flush_local to 0 after Win_flush/Win_flush_all. Modify message of decrementing AT counter to send back FLUSH if necessary. Add internal flush_local_all and flush_all. Add an assert in Win_flush_local_all to ensure all requests are completed. Improvement for IBARRIER when number of processes is 1. Modify pkt/flag/function name "FLUSH_ACK" to "ACK". Add an RMA test for issuing large ACC following by small ACCs. Bug-fix: set kind of user request in request-based RMA operation correctly. Increase timeLimit of test/mpi/rma/rma-contig to 12min. Code format clean up. Bug-fix: void function should not have return value. Bug-fix on sock: leave IOV slot for extended packet header. Bug-fix: store stream_offset in response request of GACC message. Delete unused labels to remove compiler warnings. Revert "Perf-tuning: overlapping issuing data and computation on target side in GACC/FOP." Code format clean up. Move win_shared_query to Win_fns table to let Nemesis override it. Delete RMA function table and expose "MPID_" RMA functions from CH3 to MPI layer. Code-refactoring: use MPID_Request_create routine when creating send/recv requests Make MPID_Request_complete to return mpi_errno. Add request completed callback functions. Use request_completed_cb to complete user request in req-based RMA operation. Adding a request callback function for ibarrier in Win_fence. Rename MPI_RC to MPIDI_CH3I_NM_OFI_RC Code format cleanup. fix name in state decl use double direction linked list for RMA related lists. Add an assert to check the recursion depth of MPID_Request_complete. Modify comments about request completion callback. ----------------------------------------------------------------------- hooks/post-receive -- MPICH primary repository