This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "MPICH primary repository". The annotated tag, v3.2rc1 has been created at 74d946f3cfba149dfc57a92d1f5d3c1fc6c2438a (tag) tagging 56166ffbcdfd9a2efe6fefb06317f839f6a6fa7e (commit) replaces v3.2b4 tagged by Pavan Balaji on Mon Oct 5 16:21:35 2015 -0500 - Log ----------------------------------------------------------------- Tagging 'v3.2rc1' Aaron S. Knister (1): let srun know definitiviely there's no stdin Charles J Archer (10): Move fastpath static inline to appropriate location Code refactoring to clear up naming convention. Fix ut array compile problem Generalize GPID structure for devices Second round of code refactoring MPIR_ERR_POP routines, remove if branch on error checking Per-object build fix. MPIR_THREAD_GLOBAL_MUTEX --> MPIR_THREAD_GLOBAL_ALLFUNC_MUTEX Removed unused MPIXX_Thread_tls_exit_func_t typedefs Thread package none compile/link fix Halim Amer (3): Refactor some MPI_ macros into MPIU_ Refactor USE_xx to MPIU_xx in mpiu_timer* Deleted some unused code related to Windows Huiwei Lu (8): Fix single-threaded MPIR_Get_contextid_sparse_group Fixes counters in multithreaded MPIR_Get_contextid_sparse_group Adds a test for overlapping comm_dup and comm_idup Mark comm_idup_comm2 as xfail Revert "Mark comm_idup_comm2 as xfail" Fixing a copy-paste error in comm_idup_comm2 Deprecate single-threaded MPIR_Get_contextid_sparse_group Fixing idup error handling Jeff Squyres (1): netmod/ofi: specify tx/rx ordering Jens Hauke (1): avoid dependency on GPFS if not requested Jithin Jose (1): Add fallback option for thread: MPID thread -> MPIDU thread -> MPIU thread Junchao Zhang (1): binding/f08: install all f08 module header files Ken Raffenetti (19): tsuite: whitespace cleanup tsuite: add iterations to threaded alltoall test netmod/portals4: delete unused code pm/gforker: fix compile errors related to code refactor pm/gforker: fixup for [c47e0fba0dfd] netmod/portals4: cleanup business card args netmod/portals4: fix incorrect sizeof usage binding/mpif_h: fix memory leak tsuite: add generated files to .gitignore netmod/portals4: use large type for message length tsuite: remove C99 tsuite: check the result of MPI_Get_elements_x initialize tickval with gettimeofday timer remove init_wtick from Solaris timer implementation romio: remove stop statements from fortran tests maint/jenkins: xfail test failing on Portals 4 bug binding/f08: fix vpath builds tsuite: add Fortran attr copy test with large value binding/mpif_h: promote attribute copy argument types Lena Oden (16): Use different mxm_mq_hs for send and recvme in mxm. Move commit_comm to the end of the comm_idup Remove old USE_STRICT_MPI macros Create new test for multithreaded Comm_create_group Add a new test overlapping comm_idup with comm_create_group Fix overlapping comm_idup and comm_group_create Add a new test for comm_idup error handling Add nonblocking collective error tests Modify too_many_icomms2 to wait for remaining idups Orders multiple comm_idups in a list Fix error handling from comm_idup Multiple comm_idups in different threads are not supported for socks Mark error tests for non-blocking collecvites as xfail Remove a typo from the previous commit (e0dcbdb8) Add a new test to catch a possible dead/live-lock for comm_idup New design for the ordering of context_id allocation for communicators Min Si (11): Added comment to explain why -flat-namespace is necessary. Fixed compile warning in mpi rma tests and mtest datatype routine. Added Duplicate function for MTest datatype objects. Support multiple dataset in MTest datatype routine. Added declaration for MTest basic datatype initialization. Added MTest dataset param for init/check calls in MPI tests. Revert "Added MTest dataset param for init/check calls in MPI tests" Revert "Support multiple dataset in MTest datatype routine". Revert "Added Duplicate function for MTest datatype objects". Fixed compile warning in MTest datatype. Removed unused variable in sock win_pkt_orderings_init. Paul Coffman (1): assorted fixes to ROMIO Collective IO One-sided Pavan Balaji (82): Remove unused old code. A non-zero exit code is not an error. White space cleanup. Remove xfail for idup tests. Require libtool version 2.4.6. White space cleanup of the test suite. Update version number in preparation for the 3.2rc1 release. Revert overzealous white space cleanup in [b722a2422dbd]. Rename fence request callback and move it to where it's used. Rename dangling_request_cnt to sync_request_cnt. Add a callback for PSCW request completions. Set window to active when receiving Lock ACK. Update author list for the MPICH user guides. Added more mailmaps to deal with changed email addresses. Added a new test for duping many comms with idup. Minor cleanup for context_id allocation White space cleanup for the commutil file. Separate out context ID allocation into a different file. Remove function namespacing for static functions. Get rid of the old MPIR_Get_contextid function. Convert camelcase variables to underscore format. RMA code Cleanup. Rename MPIR_CVAR_NEMESIS_POLLS_BEFORE_YIELD. Cleanup unnecessary commented out redefinition of MPID_Abort. Remove commented out content. Cleanup timer functionality. Added search/replace script to the maint directory. White space cleanup. Remove useless redefinitions of MPIU_Wtime_init. Remove unused CH3-specific CS functionality. Use macros instead of direct mutex names to make the code cleaner. Remove redundant definition of MPIU_Wtick. unistd.h is needed for some of the timer functionality. Bug-fix: PGI compiler failure. Added missing inclusion of mpimem.h, which is needed for MPIU_Calloc. Use MPIU_Thread_ptr instead of MPIU_Thread. Bug-fix: Handle icc failures on Darwin with thread local storage. Simplify the device thread functionality for ch3. Remove unused macros. Remove unnecessary and incorrect comment. Prefix MPICH-defined constants with MPICH. Remove C99 semantics. Remove non-error-checking variants of mutex functions. List FIXME in one place instead of repeating it everywhere. White space cleanup. Get rid of unused trylock functionality. Minor comment fix. First round of cleanup for ROMIO threading. Bug-fix: Part of adioi.h code was outside the header macro protection. Make error checking unlikely. Consistently add error checking in all threading code. Initial draft of ROMIO managed thread locks. Get rid of recursive locks. Simplify threading code. Remove mpiu_timer.h. Remove unused variable. Handle mutex is only used in the per-object code. Make memalloc_mutex consistent with the other mutexes. Separate out thread_storage to be only be available for thread multiple. Have each threads implementation define what it exposes as functions/macros. Get rid of the types/funcs separation for each threads implementation. Remove unused macro. Rename files for consistency. Rename MPICH_ThreadInfo_t to MPIR_Thread_info_t. Remove incorrect redundant structure name. MPICH_PerThread_t should be MPIU_Per_thread_t. Remove unnecessary enum. MPIU_ to MPICH_ conversion for configure-generated macros. Convert internal MPIU_ variables and macros to MPIUI_. Rename MPEI functionality to MPIUI. MPIU_OBJ_PUBLISH_HANDLE should not be used directly. MPIR_THREAD_GRANULARITY should be MPICH_THREAD_GRANULARITY. Expose MPIU_THREADPRIV macros through MPID. Remove unused datatype. Remove unused declarations of thread private variables. Replace the direct usage of MPIU_Thread with MPID_Thread. Remove unused thread-private declarations. Rename MPIUI_THREAD_CS_*_REAL to MPIUI_THREAD_CS_*_NONRECURSIVE. Added back the implementation of recursive locks. Remove unused declarations. Rename POBJ mutexes to better namespace them. Move memalloc mutex to an all-granularity mutex. Rob Latham (17): test case for "unable to create file" try to more gracefully handle out of memory conditions move hint dumping a bit later hint processing should not open files do not want generic hints to override this lustre hint remove bogus double-seek from hint processing fix Laying foundation for new features for Panasas configure-time check for newer PanFS features move flattend resolution to a separate function sync ROMIO locations that touch global state fixup: misspelled variable error pointer left uninitialized in stub case address "potentially used uninitialized" warnings clang finds a few shadowed and unused declarations implement and use MPL_strerror Revert "Initial draft of ROMIO managed thread locks." Revert "sync ROMIO locations that touch global state" Ron Victorelli (1): Remove RAID0 support and add RAIDN to MPICH Sangmin Seo (2): romio: add MPIR_Ext_cs_yield_global. romio: add matching MPIR_Ext_cs_exit calls. William Gropp (3): Fixes for coverage target. Remove trailing blanks and typo in Makefile Fix misspelled comment in getcoverage William Throwe (1): ROMIO configure looks for lstat in wrong header Xin Zhao (53): Add initialization of request_handle in the request object. Make request completion callback to delete operation and drop GC progress. Add bracket to protect variable name in the macro. Simplify function dealing with operation piggybacked with LOCK. Simplify RMA issuing functions. Add helper macros to simplify the code. Delete MPIDI_RMA_Win_list_t struct. Rename "non_empty_slots" to "num_active_slots". Bug-fix: mark stream units are all issued when issued count equals to total count. Rename function adjust_op_piggybacked_with_lock to handle_lock_ack_with_op Issue UNLOCK/FLUSH message right after lock is granted. Use sync_request_cnt to count total number of ibarrier requests. Use num_targets_with_pending_ops instead of num_active_slots. Add active/inactive window lists. Modify Fence cb function to activate/de-activate window. Delete window state switch in RMA progress. Delete unused function argument. Delete MPIDI_CH3I_num_active_issued_win and MPIDI_CH3I_num_passive_win. Register/de-register RMA progress when activate/de-activate window. Bug-fix when Lock Ack is LOCK_QUEUED_DATA_QUEUED. Rename variable num_targets_with_pending_ops to num_targets_with_pending_net_ops Split pending op list into pending_net_ops_list and pending_user_ops_list. move static function check_and_set_req_completion to header file. Bug-fix: call check_and_set_req_completion for OP piggybacked with lock. Delete useless if branch. Release the request after modifying the attributes of it. Delete redundant function definitions. Delete unnecessary condition. Remove the restriction of FENCE/PSCW_GRANTED state in RMA progress. Make issue_ops_target not re-entrant. Delete comment that makes no sense. Simplify macros for RMA op. Free RMA op object immediately after it is issued out. Use counter num_ops_flush_not_issued to control issuing of FLUSH messages. Make active_req_cnt as a global variable. Reduce default value of MPIR_CVAR_CH3_RMA_ACTIVE_REQ_THRESHOLD. Delete redundant function call. Add an assert to check MPIDI_CH3I_RMA_Active_req_cnt. Bug-fix on RMA working with asynchronous thread. Increase time limit of some GACC-based RMA tests to 4 min. Keep track of how many progress hooks are currently registered. Add missed optimization for sock and pamid. Modify Proress_register/deregister_hook to return/pass id argument. Move RMA progress_register/de-register_hook to Win_init/free. Add Progress_activate/de-activate_hook routines. Increase time limit of some GACC-based RMA tests to 4 min. Revert "Keep track of how many progress hooks are currently registered." Revert "Add missed optimization for sock and pamid." Set MAX_PROGRESS_HOOKS to 4 to reduce overhead of progress engine. Bug-fix on MPIDI_CH3I_Win_find_target. Wait for outstanding ACKs in ending synchronization calls. Modify comments. Code cleanup. Yanfei Guo (13): Remove the use of C99 syntax (declarations after statements) Add the missing return 0 for idup-tests; Clean up empty lines in comm_idup tests Add new tests for keyval double freeing Add build scripts for Jenkins test jobs Add scripts for setting XFAIL maint/jenkins: enable full test for nightly jobs maint/jenkins: add script to skip tests maint/jenkins: fix a bug in the set-xfail.sh script maint/jenkins: untar MPICH tarball on local disk testsuite: comment out new keyval double free tests maint/jenkins: fix dir creation bug in test-worker.sh Fix bug in attr double freeing tests and reenable the tests ----------------------------------------------------------------------- hooks/post-receive -- MPICH primary repository