I read the document again and found sentences like " This routine returns MPI_SUCCESS on success and returns MPI_T_ERR_INVALID_NAME if name does not match the name of any control variable provided by the implementation at the time of the call". So I think it is clear we should always return INVALID_* for inactive vars.
Forgive me for the oversight.

--Junchao Zhang


On Thu, Feb 20, 2014 at 6:10 PM, Junchao Zhang <jczhang@mcs.anl.gov> wrote:
Hi,
  From the agenda, it seems all tickets for voting at the March meeting are tools.
  I have a question about ticket 377, which adds an error code "MPI_T_ERR_INVALID_NAME -- The variable or category name is invalid".  Remember we also use the word in the other case like "The variable index is invalid".  So, what is the meaning of invalid in these two cases?
  I raise this question because in the text we have "When a variable becomes inactive, e.g., through dynamic unloading, accessing its value should return a corresponding error code."  Then, what operations are thought as "accessing its values". Instead of *var_read, can I get_info of an inactive variable? The answer will affect the definition of "invalid" in cases above.  So, I think we'd better clarify that.

--Junchao Zhang