Re: [Mpi3-ft] NUM_STATE vs STATE_SIZE
My only concern is that "MPI_*_VALIDATE_STATE_SIZE" makes me think about the 'size of the state object' instead of 'the number of states being returned'. But I'm fine with the change if others are. I think there was also a more general concern about the validate function names - making them read a bit better. But I cannot find a clear note about this issue in particular. -- Josh On Thu, Jun 23, 2011 at 2:46 PM, Darius Buntinas <[email protected]> wrote:
A few calls ago, we discussed whether to use MPI_*_VALIDATE_NUM_STATE() vs MPI_*_VALIDATE_STATE_SIZE() to return the number of entries that would be returned by MPI_*_VALIDATE_GET_STATE().
Doing a string search through the standard reveals that there are no matches for "_num" outside other than in the FT chapter for MPI_*_VALIDATE_NUM_STATE. �On the other hand, there are many matches for "_SIZE", e.g., MPI_COMM_SIZE, MPI_PACK_SIZE, MPI_TYPE_SIZE and MPI_GROUP_SIZE.
So based on precedence (and because I like it better), I think we should use MPI_*_VALIDATE_STATE_SIZE.
Comments?
-d
_______________________________________________ mpi3-ft mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-ft
-- Joshua Hursey Postdoctoral Research Associate Oak Ridge National Laboratory http://users.nccs.gov/~jjhursey
participants (1)
-
Josh Hursey