Re: [Mpi3-ft] Invalidate by any other name
revoke +1. george. On Mar 12, 2012, at 10:52 , Josh Hursey wrote:
One of the lingering syntax issues from the MPI Forum meeting last week has to do with the MPI_*_invalidate() operation.
"Invalid communicator" has a well defined meaning in the MPI standard, so it is bad to have an alternative meeting for the FT functionally. Therefore, we need a new name for this 'invalidate' operation.
Below are some suggestions (thanks to Jeff Squyres and Thomas Herault for some of these):
suspend annul negate discredit disqualify neutralize quash revoke rescind repeal revoke nuke nix explode smite infirmo
Are there others that folks want to suggest?
I kind of like 'repeal' or 'revoke' since we are revoking the context associated with the communication object through this function.
-- Josh
-- Joshua Hursey Postdoctoral Research Associate Oak Ridge National Laboratory http://users.nccs.gov/~jjhursey _______________________________________________ mpi3-ft mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-ft
participants (1)
-
George Bosilca