Re: [Mpi3-ft] reenable_anysource
-----Original Message----- From: [email protected] [mailto:mpi3-ft- [email protected]] On Behalf Of Darius Buntinas Sent: Friday, December 09, 2011 2:22 PM To: MPI 3.0 Fault Tolerance and Dynamic Process Control working Group Subject: [Mpi3-ft] reenable_anysource
We've proposed MPI_Comm_reenable_anysource that returns a group containing the failed processes known to the process at the time of the failure.
Don't we need another function for intercommunicators that returns two groups of failed processes: one for the local group and another for the remote group?
MPI_Comm_reenable_anysource_inter? (now we're definitely over 30 characters).
Yes, but as long as it is < 140 characters, do we really care? I mean, we could still tweet about the function ;) (sorry, couldn't resist) How about we have the same name and have some arg ignored? MPI_Comm_reenable_anysource(comm, failed_local_group, failed_remote_group) With failed_remote_group only valid if comm is inter? Or does that violate some naming convention?
-d
_______________________________________________ mpi3-ft mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-ft
participants (1)
-
Sur, Sayantan