Re: [Mpi3-ft] Invalidate by any other name
I like revoke too Aurelien Le 12 mars 2012 à 17:22, Thomas Herault a écrit :
revoke +1
Thomas
Le 12 mars 2012 à 12:41, Darius Buntinas a écrit :
terminate retire abate
-d
On Mar 12, 2012, at 11:34 AM, Darius Buntinas wrote:
disable?
-d
On Mar 12, 2012, at 9:52 AM, Josh Hursey wrote:
One of the lingering syntax issues from the MPI Forum meeting last week has to do with the MPI_*_invalidate() operation.
"Invalid communicator" has a well defined meaning in the MPI standard, so it is bad to have an alternative meeting for the FT functionally. Therefore, we need a new name for this 'invalidate' operation.
Below are some suggestions (thanks to Jeff Squyres and Thomas Herault for some of these):
suspend annul negate discredit disqualify neutralize quash revoke rescind repeal revoke nuke nix explode smite infirmo
Are there others that folks want to suggest?
I kind of like 'repeal' or 'revoke' since we are revoking the context associated with the communication object through this function.
-- Josh
-- Joshua Hursey Postdoctoral Research Associate Oak Ridge National Laboratory http://users.nccs.gov/~jjhursey _______________________________________________ mpi3-ft mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-ft
_______________________________________________ mpi3-ft mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-ft
_______________________________________________ mpi3-ft mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-ft
-- * Dr. Aurélien Bouteiller * Researcher at Innovative Computing Laboratory * University of Tennessee * 1122 Volunteer Boulevard, suite 350 * Knoxville, TN 37996 * 865 974 6321
participants (1)
-
Aurélien Bouteiller