Re: [MPI3 Fortran] MPI function symbol naming convention for tools
We've debated this for some time and the module name chosen is "mpi_f08". We had originally proposed the module name to be "mpi3" but this ties the name to a particular mpi version which didn't seem the right thing to do. I'm open to a different module name though Rolf will probably kill me. Perhaps "use mpi_f_types" or "use mpi_f_handles". Though it is late in the game to be making a name change now. -craig On Jun 20, 2011, at 12:19 PM, Lionel, Steve wrote:
3. mpi_recv_f08 - This function implements (in C or Fortran) MPI_Recv with integer handles and the choice buffer passed via an array descriptor.
Note that these functions only need to support integer handles because of the way we (thanks to Rolf) have chosen to define the handle types in the mpi_f08 module.
Please comment on this naming convention.
I would request that any names NOT include text that refers to a specific version of the Fortran standard. The industry already made that mistake once with the .f90 file type meaning "free-form source" - I don't want to see the mistake repeated. Maybe "fdesc" can be used, or something else that has the right connotation without implying some specific standard revision.
Steve Lionel Intel Developer Support Merrimack, NH
_______________________________________________ mpi3-fortran mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-fortran
participants (1)
-
Rasmussen, Craig E