Re: [mpi3-coll] [Mpi-forum] MPI_Comm_create_group Meeting
Hi Bronis, Thanks very much for the feedback. I've created a ticket (#305) with some initial text for MPI_Intercomm_create: https://svn.mpi-forum.org/trac/mpi-forum-web/ticket/305 I updated the MPI_Comm_create_group text with your corrections and also made some additional updates to the tags paragraph (page 228, line 12) to hopefully address a few other questions I got off-list. A new PDF is attached. I'd appreciate a second look if you have time. Thanks, ~Jim. On 12/7/11 9:00 PM, Bronis R. de Supinski wrote:
Jim:
I think it would be good to create a companion ticket to make MPI_Intercomm_create use the tag space. We should get that ticket ready now (I expect it is just a few lines of change) so that it will be in MPI 3.0, assuming ticket 286 passes.
Anyway, please change:
"new intracommunicator, newcomm, whose communication group is defined by the group argument."
to:
"new intracommunicator, newcomm, for which the group argument defines the communication group."
Also, please change:
"to order calls and/or use different tag arguments"
to
"to order calls and/or to use differenttag arguments"
Bronis
On Wed, 7 Dec 2011, Jim Dinan wrote:
Hi All,
I've updated the text with feedback from the last meeting, adding text to define a collective tag space. Please take a look at the ticket286 edits in the attached PDF and send any feedback.
Also, I'd like to have another conference call early next week to discuss and get ready for a reading in January. Please fill in your availability on the doodle poll:
http://www.doodle.com/yx5b2f5f5hwc2qzq
Thanks, ~Jim.
On 11/8/11 3:57 PM, James Dinan wrote:
Hi All,
Notes from yesterday's meeting are attached. Please note that we are moving all future discussion of this ticket to the mpi3-coll mailing list.
Best, ~Jim.
In attendance:
Adam Moody, David Goodell, Jim Dinan, Pavan Balaji, Fab Tiller, Bronis de Supinski, Jeff Hammond
Item 1: Name of the routine.
We decided to stick with MPI_Comm_create group as the best way of matching the MPI_CLASS_ACTION_SUBSET naming convention.
Item 2: Tag versus color.
We decided to use a tag, which is defined to be in a collective tag space that is distinct from the point-to-point tag space. The collective tag will follow all MPI tag semantics, however it will not conflict with any point-to-point tags (including MPI_ANY_TAG). This essentially exposes the expected implementation in the standard, providing more flexible semantics to the user. In addition, it allows an implementation to make more efficient use of the tag space by defining tag conflicts across tagged collective operations (currently only MPI_Intercomm_create and MPI_Comm_create_group, but we could define others in the future).
In a separate ticket, we can update MPI_Intercomm_create to specify that its tag is also in the collective tag space. This will be backward compatible, but will make MPI_Intercomm_create considerably easier to use because its tags will no longer conflict with point-to-point operations.
Tasks:
* Jim will work on a revision of the text that follows the above semantics.
* The group will reconvene after Thanksgiving to review new text.
* The group will move discussion to the collectives mailing list.
On 11/4/11 11:07 AM, James Dinan wrote:
Based on the doodle poll, it looks like Monday at 3pm CT will be the best time to meet. We'll use the hybrid WG telecon bridge:
Domestic dial number: 866-654-6744 International dial number: 517-308-8226 Passcode: 6086006
See you then, ~Jim.
On 11/1/11 2:33 PM, James Dinan wrote:
Hi All,
I would like to form a group to review the MPI_Comm_create_group() proposal (#286) for a formal reading at the next Forum meeting. If you are interested in joining the discussion, could you please fill in your availability for a one hour conference call next week:
http://www.doodle.com/9tganzq2hqiqy7kt
We have a couple issues to discuss:
1.) The name of the function: MPI_Comm_create_group, MPI_Group_comm_create, MPI_Comm_create_from_group, ...
2.) The tag argument: Should we use a tag or a "color" to establish a safe communication conduit on the parent communicator. As discussed at the Forum, using a tag could conflict with the use of MPI_ANY_TAG on the parent communicator. A color would avoid this issue, however it could complicate tag matching.
3.) Changes to the text.
Thanks, ~Jim.
PS- I've attached a copy of the current text with comments from the formal reading at the last Forum meeting (in Acrobat: Comments -> Comments View -> Show Comments List for the full list).
_______________________________________________ mpi-forum mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-forum
mpi-forum mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-forum
mpi-forum mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-forum
_______________________________________________ mpi3-coll mailing list [email protected] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-coll
participants (1)
-
Jim Dinan