Re: [Mpi3-bwcompat] MPI_Count mixing with int...
Hi Fab, Sorry for the delay in replying... On Jul 9, 2010, at 2:22 PM, Fab Tillier wrote:
Quincey Koziol wrote on Fri, 9 Jul 2010 at 12:05:52
I still think aliasing MPI_Size and MPI_Count will cause problems down the line, since the two concepts are different. I'd be much happier with separating them now rather than having to change things that are switched from int to MPI_Size now to MPI_Count later.
Having MPI_Size and MPI_Count different types causes MPI_Pack/MPI_Send and MPI_Recv/MPI_Unpack to have problems, since the count and sizes are passed between the two functions and should be interchangeable, though.
Well, there probably is something wrong with the definition of MPI_Pack and MPI_Unpack then. OK, I've gone off and re-read the definition of MPI_Pack in the standard and it looks OK to me. What is the problem with using MPI_Count for the 'incount' parameter and MPI_Size for the 'outsize' parameter? (I think I would suggest changing 'inposition' from a 'int *' to a 'void *' while we're mucking about in here, also) Quincey
Do we not care, and assume the compiler will flag assignments that might result in truncation?
-Fab
_______________________________________________ Mpi3-bwcompat mailing list Mpi3-bwcompat_at_[hidden] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-bwcompat
participants (1)
-
unknown@example.com