Re: [Mpi3-bwcompat] MPI_Count mixing with int...
Quincey Koziol wrote on Thu, 8 Jul 2010 at 06:44:37
On Jul 7, 2010, at 8:16 AM, Rajeev Thakur wrote:
Can we define both (to be the same) since we are familiar with count for messages (it is a count of datatypes) and size for others.
I agree - we shouldn't conflate counts and sizes, they are totally different things. Defining them both makes sense to me.
But they are the same for the MPI_PACKED datatype, so really shouldn't be different. As an aside, can count ever be larger than size_t? -Fab
-----Original Message----- From: mpi3-bwcompat-bounces_at_[hidden] [mailto:mpi3-bwcompat-bounces_at_[hidden]] On Behalf Of Jeff Squyres Sent: Wednesday, July 07, 2010 7:24 AM To: MPI-3 backwards compatability WG Subject: Re: [Mpi3-bwcompat] MPI_Count mixing with int...
On Jul 7, 2010, at 2:23 AM, Fab Tillier wrote:
Would anyone object if we defined MPI_Size rather than MPI_Count, and used it for count, position, and size parameters? We could then tackle the issues with MPI_Pack/Unpack/Pack_size/Type_size at the same time as counts. We can't use MPI_Aint here since we want to be able to be backward compatible, so must provide a separate type that can be defined as a standard integer.
I agree that tackling them all at the same time is the Right Thing to do. I also agree with all your other points.
I still am a little uncomfortable with the name "MPI_Size" because sizes and counts are theoretically different things. But then again, I can't think of a better name offhand...
-- Jeff Squyres jsquyres_at_[hidden] For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
_______________________________________________ Mpi3-bwcompat mailing list Mpi3-bwcompat_at_[hidden] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-bwcompat
_______________________________________________ Mpi3-bwcompat mailing list Mpi3-bwcompat_at_[hidden] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-bwcompat
_______________________________________________ Mpi3-bwcompat mailing list Mpi3-bwcompat_at_[hidden] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi3-bwcompat
participants (1)
-
unknown@example.com