Re: [Mpi3-bwcompat] MPI_Count mixing with int...
On Jul 7, 2010, at 2:23 AM, Fab Tillier wrote:
Would anyone object if we defined MPI_Size rather than MPI_Count, and used it for count, position, and size parameters? We could then tackle the issues with MPI_Pack/Unpack/Pack_size/Type_size at the same time as counts. We can't use MPI_Aint here since we want to be able to be backward compatible, so must provide a separate type that can be defined as a standard integer.
I agree that tackling them all at the same time is the Right Thing to do. I also agree with all your other points. I still am a little uncomfortable with the name "MPI_Size" because sizes and counts are theoretically different things. But then again, I can't think of a better name offhand... -- Jeff Squyres jsquyres_at_[hidden] For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
participants (1)
-
unknown@example.com