Re: [Mpi-22] [MPI Forum] #55: MPI-2.1 Cross-language attribute example is wrong
Eek! Not for 2.2 ! Maybe a historical advice to users .... Bill On Jan 27, 2009, at 4:49 PM, Jeff Squyres wrote:
On Jan 27, 2009, at 5:35 PM, William Gropp wrote:
On the last point, the real answer is that since the attributes behave as if they were set by the now deprecated functions, they should themselves be deprecated, since we must not change their behavior. This is also the source of the int/MPI_Fint issue - there was no MPI_Fint in MPI-1.
Wow, the scope of this ticket keeps expanding. :-)
I see the following attributes in OMPI's mpi.h:
/* MPI-1 */ MPI_TAG_UB, MPI_HOST, MPI_IO, MPI_WTIME_IS_GLOBAL,
/* MPI-2 */ MPI_APPNUM, MPI_LASTUSEDCODE, MPI_UNIVERSE_SIZE, MPI_WIN_BASE, MPI_WIN_SIZE, MPI_WIN_DISP_UNIT,
Excluding MPI_WIN_BASE (which, IIRC, is the only address-sized attribute in this list), if we deprecate these names, I assume we'll simply replace them with new names that behave as if they were set from Fortran MPI_COMM_SET_ATTR. Specifically, the sizes of the values will be such that you have to access them with INTEGER(KIND=MPI_ADDRESS_KIND) and (MPI_Aint*).
Is that what you're thinking? If so, how about s/MPI_/MPI_ATTR_/ in all the names (perhaps also creating an alias for MPI_WIN_BASE -> MPI_ATTR_WIN_BASE just for symmetry)? I'm open to suggestions for new names.
I'd almost prefer to make that a separate (but related) ticket -- the issues in #55 are already quite tangled... (i.e., leave out any mention of the predefined attributes from #55 and have a new ticket for those issues) Sound reasonable?
-- Jeff Squyres Cisco Systems
_______________________________________________ mpi-22 mailing list mpi-22_at_[hidden] http://lists.mpi-forum.org/mailman/listinfo.cgi/mpi-22
William Gropp Deputy Director for Research Institute for Advanced Computing Applications and Technologies Paul and Cynthia Saylor Professor of Computer Science University of Illinois Urbana-Champaign
participants (1)
-
unknown@example.com