[mpich] MPICH primary repository annotated tag, v3.1rc3, created. v3.1rc3
This is an automated email from the git hooks/post-receive script. It was generated because a ref change was pushed to the repository containing the project "MPICH primary repository". The annotated tag, v3.1rc3 has been created at c0fe4f463eed85052d58bd131b51f9ce4d71e5d0 (tag) tagging 1bef988953257fb6acababd5e3af17bad2b91e9c (commit) replaces v3.1rc2 tagged by Ken Raffenetti on Tue Feb 4 13:20:32 2014 -0600 - Log ----------------------------------------------------------------- tagging 'v3.1rc3' Antonio J. Pena (12): Removed ancient comments in dims_create.c Fixed suboptimal distributions in MPI_Dims_create Added regression test for ticket #1765 Fix warnings in ch3u_rma_acc_ops and ch3u_rma_ops Fix compiler warning in socksm.c Fix warnings in initcxx.cxx with Portland compiler Fix warnings in initcxx.cxx with Portland compiler Fix compiler warnings about unused variables Fix compiler warnings about variables for assert Enclose into #ifdef code causing compiler warnings Fix warnings in variables only used in assertions Fix compiler warnings in hwloc with --enable-fast Bob Cernohous (1): Test updates for ad_bglockless. Gilles Gouaillardet (3): Use MPI_Count with MPIR_Status_set_bytes. Use MPI_Type_size_x. Fix prototypes and remove unused local variables. Haizhu Liu (3): Exit with error when dynamic tasking is used in an invalid environment PAMID support of request based rma functions PAMID support of rma atomic functions Huiwei Lu (1): Updates testing scripts to generate junit output James Dinan (2): Improve context ID exhaustion error reporting Update comm_create to use sparse ctx id allocation Junchao Zhang (34): Fix a typo about MPIR_CVAR_NEM_* Make extracterrmsgs know MPI_T error codes Add MPIR_ERRTEST_* macros for MPI_T Improve MPI_T error handling Revise the test to add MPI_T_PVAR_ALL_HANDLES Delete mpiinstr.h since it is superceeded by MPI_T Add rma to option --enable-mpit-pvars=list Change prototype of MPIR_T_pvar_get_value_cb etc Let MPIR_T_PVAR_*_GET_VAR() act as a rvalue Add a counter into structure MPIR_T_pvar_timer_t Add macro MPIR_T_PVAR_{COUNTER, TIMER}_ADDR Fix a bug in MPI_T watermark pvar registeration Port instr variables in rma code to MPI_T pvars Use if (ENABLE_PVAR_NEM) instead of #ifdef Enclose macro arguments in parentheses Delete cvars.yml since it will be split. Rename script gencvars to extractcvars Implement extractcvars, which extracts cvar info. Fix a wrong cvar name Revert commented out code, to make a cvar work Spread out cvar info into source files Revise description of MPIR_CVAR_BCAST_* cvars Add the missing NEMESIS_LMT_DMA_THRESHOLD Add indentions, remove white spaces, replace Tabs Make ReadInterface extract both arg types & names Add indentions, remove white spaces, replace Tabs Print dummy arg names defined by MPI to f90 files Fix a script problem appearing in old perl Add prefix MPI_CVAR_ to a cvar name in description white space fixup Add "See also" in descriptions of related cvars Disable Clang's type checking for MPI_2INT Add return 0 to the main function of tests Add -lgcov to LIBS when --enable-coverage Ken Raffenetti (32): require 8-byte memory address for large mem tests fixup for 1638ed88 correct alias option test for weak attributes Revert "correct alias option test for weak attributes" strengthen test for weak alias attribute set context mask depending on need for ICOMM_WORLD disable win_large_shm test when unsupported extend timeout for large sendrec test warning squashes for hwloc format warning squash patch to detect bgq compilers in config.rpath corrections to weak alias test Improve pkg-config support compile wrapper cleanup gitignore generated mpivars file corrections to compile wrapper changes simplify bitmap intialization in process binding example program to display processor affinity hydra process binding/mapping overhaul remove help text for unsupported mapping option add debugging for process affinity options make topology debugging output more reliable add manual test for process affinity mark cas_type_check test as xfail handle when qsort is not available in vc setup use pmi as default name service fix for unpublish name behavior error reporting corrections in pmi nameservice corrects the MPI error class returned from MPI_Unpublish_name. check for correct errclass in unpub test return correct error code in MPI_UNPUBLISH_NAME remove unnecessary system-out data in junit Masamichi Takagi (23): Add netmod files for Xeon Phi on DCFA/McKernel Use MPIR_STATUS_SET_COUNT for the request struct Comment out debug messages in dcfa_impl.h Correct error string Add Fortran related cross compilation values Modify macro name for DCFA specific lines Enable --with-dcfa* configure options Add a description on the DCFA network module Auto-detect IB libraries for the DCFA netmod Eliminate --enable-strict warnings and errors Increase max number of connections Correct reference overrun in debug message Modify credit information packet rate Correct debug messages Remove macro for receiver-initiate lmt Rename the DCFA netmod to the IB netmod Add a header file to Makefile.mk of ib netmod Replace MPIU_QUOTE with MPIDI_QUOTE Remove obsolete code Correct references to "subtype" of netmod packets Modify README.vin on description of the IB netmod Fix type names in the IB netmod Fix warnings and errors with --enable-strict Michael Blocksome (6): PAMId: added some mpi 3.0 RMA function support Set the maximum number of PAMI contexts to use to '1' for PE Add missing FCNAME #define for error reporting. fix missing const for MPID_Accumulate and MPID_Put functions. gcc 4.4.6 warning cleanup. bgq fix for mpivars link error Nysal Jan K.A (2): Initialize the dbg_next field of the mpi request Fix MPI_Attr_put on big-endian systems Pavan Balaji (54): Move brace outside of the ifdef, so it's always defined. Remove misplaced brace. White-space cleanup. Check for number of arguments instead of a NULL argument. Upgrade to hwloc-1.8 Hydra-specific patches for hwloc. Update CHANGES file for hwloc-1.8. Added more MPICH authors and removed old ones. White space cleanup. White-space cleanup for redability. Added a new comm_idup_overlap test. Create a dummy stdin socket instead of simply closing it. Move default eager threshold setting to ch3. Add primes to cover till 2 billion MPI ranks. Added a new dims_create test. Change variable name and add more comments. Bug-fix: reset the rmk when the hostlist came from the user. Bug-fix: win_req was never initialized. Remove duplicate code. Make SMP-awareness in MPI_Barrier consistent. pamid is capable of supporting WIN_UNIFIED. Thread critical-section initialization fixes. We always need the runtime thread-safety check. Prioritize thread-multiple branch. Comment out nb_test, since it's not entirely correct. White space cleanup. Time iterations and break out if we are too slow. Rename MPICH2 to MPICH. Update the MPICH ABI string for the 3.1rc3 release. Use MPIU_Malloc/Free instead of malloc/free. White space cleanup. Move communicator destruction to after progress checks. Revert "Move communicator destruction to after progress checks." Remove unused flag. Improve PMI_process_mapping parsing. Bug-fix: deal with wrap around PMI process mapping strings Move communicator destruction to after progress checks. Provide a way to disable ssh warnings in Hydra. Remove xfail for ticket-1996, which is closed. Delete some windows-related code. Fix broken release script from [ba3badff]. Require correct autotool versions for a release. Update copyright information for Jeff Hammond's tests. Added a bunch of other copyrights. Revamp how enable-fast is used. Update README to tell users how to do performance testing. Remove MPICH_FAST usage from the test suite. Bug-fix: bad declaration when error checking is disabled. Reduce the number of processes needed by rma-contig. Rename binding reference files to be windows-friendly. Update CHANGES file for the rc3 release. Remove release notes that are no longer relevant. Remove .bat files. Remove .bat file checks in Makefile. Rob Latham (20): fix compile errors with lustre ROMIO standalone: check for MPI_Count ROMIO standalone: remove internal headers ROMIO standalone: check HINDEXED_BLOCK ROMIO standalone: check for need of const deal with "infinitely stale" case re-enable deferred open on Blue Gene Introduce and use ADIO_TWO_PHASE feature-check deferred open: fixup immediate-mode communicators unused variable warning ROMIO standalone: actually install library ROMIO standalone: fix up link-time errors ROMIO standalone: check for large-count routines bluegene open fixup: don't broadcast garbage bring back include file needed for MPI_AINT_CAST_TO_VOID_PTR Revert "bring back include file needed for MPI_AINT_CAST_TO_VOID_PTR" Use ROMIO pointer-casting routines release memory in error path a partial round of datatype optimizations Revert "a partial round of datatype optimizations" Sameer Kumar (2): Implement MPID_Get_accumulate() Bug fix for strided datatypes. Sameh Sharkawi (6): Task flooding causes poor MPI_Reduce performance Fixes for Collective Selection enablement Fixes for MPI_Alltoall when using non-contig data and collective selection Debug lib memory tracing signature Allow env variables to control memory initialization. PAMID fix for schedule release Su Huang (9): PAMId: MPI_Win_set_info, MPI_Win_get_info and the frame work for window creation PAMID: Support MPI_PROC_NULL in MPI_Win_lock and MPI_Win_unlock PAMID: update PE trace code to support MPI_ANY_SOURCE PAMID: MPID_Win_allocate_shared and MPID_Win_shared_query support PAMID: fixes for MPI_Win_* PAMID: segfault occurred in MPIDI_Win_DoneCB Fix multiple FCNAME declarations error. PAMID: fix memory leak problem PAMID:fix memory leak and BGQ problems Wesley Bland (9): Update the changes file for 3.1rc2 Cleanup generated test files. Add doctext to hydra build system. Add man page for missing hydra executables Mark the ft/die test as xfail for now. Mark ft/sendalive as xfail for now. Moves the tag reservation to MPI layer Remove a comment that doesn't apply anymore. Add configure option to disable FT tests William Gropp (7): Minor typo corrections in PAC macros comments Fix check for datatype name Add program to show MPI_T variables Fix typo in library choice for mpivars Add mpivars to build Fix typos in mpivars Fix bogus datatype perf test ----------------------------------------------------------------------- hooks/post-receive -- MPICH primary repository
participants (1)
-
noreply@mpich.org